Translate

quinta-feira, 13 de março de 2014

Problemas Danfe AX2012 e Codigo de Barras.

Olá pessoal!

Mais um problema solucionado hoje!!! Então vamos compartilhar a experiência!

Um consultor nos relatou um problema em um ambiente de homologação de um cliente. O problema era durante a impressão de danfes no AX2012 deste ambiente. Ao visualizar a impressão de uma danfe o codigo de barras nao era exibido corretamente, ao invez dele eram exibidos apenas simbolos, caracteres especiais.

Na imagem abaixo, mesmo desfocada e com campos apagados podemos ver os caracteres especiais ao invés do código de barra.

Hoje consegui entender exatamente qual o problema...

Esta tela é na verdade um relatorio do AX2012, o nome do report na AOT é EFDocDANFE_BR.

Eu realmente nao sabia disso...só descobri hoje!!!!!

Sabendo disso imaginei que o tamanho do campo estava pequeno para exibir corretamente o código de barras e por isso apareciam apenas caracteres especiais. Parecido com o Excel!!!

Queria abrir as propriedades do relatório para verificar esta configuração e pra isso precisei instalar o Visual Studio Tools, durante esta instalação eu precisei reiniciar o serviço do SSRS.

Após instalar o Visual Studio Tools eu abri novamente o AX e tentei imprimir a danfe novamente. Para minha surpresa a danfe foi impressa corretamente exibindo o codigo de barras perfeitamente...!!!

Resumindo, a solução para o problema foi apenas reiniciar o serviço do Reporting Services no servidor de relatórios, só isso!!!

Até a próxima pessoal!